War3 FATAL Error Fixing Method

Not open for further replies.


Premium Member
this application has encountered a critical error: fatal error!
program: d:\program files\warcraft iii\war3.exe
exception: oxcoooooo5 (access_violation) at 016F:0306A6A8
the instruction at¡¯0x0306A6A8¡¯ referenced memory at ¡¯0xFFFFFA66¡¯
the memmory could not be ¡¯written¡¯
press ok to terminate the application
If this is what you get or something like this when you start Warcraft III: RoC or TFT... and your Warcraft III just turns off.. heres somethings you should do:
-Restart the Game.
-Restart Computer

However, if you still get Fatal Errors:
-Update your video card
-Update your sound card
-Change/alter your sound card information

^ If you are using AVANCE sound card:
http://ftp.blizzard.com/pub/war3/other/AvanceFix.reg DL this (registry file)
^ If you are using SOUND MAX:
http://ftp.blizzard.com/pub/war3/other/soundmax.reg DL this (registry file)

These should fix your problems.

***If it still give you "FATAL ERROR" then:
-Reset the War3 it self:
http://ftp.blizzard.com/pub/war3/other/war3.reg DL THIS (registry file)

GL and Enjoy warcraft


Guy with Most Posts on Quiet Board.
Hellwolf's Solutions to fixing this error


Greetings Forum Surfers and newcomers. If N_'s guide doesn't help you with the problem (Trust me, it won't). My LONG guide of solutions should be able to fix your solutions. This will work with generally any 0x8E (Unhandled Exception) or 0xC4 error. How I know these will work? I have written this guide thru experience since my first computer suffered like this. I fixed it with a new PSU and DRAM Voltage, now it crashes from triggers :). However, I have no assurance whatsoever that your problem will get worse, you decided to do this so do the advanced issues at your own risk :).

-Bad Drivers
Update your video card when new drivers come out. Go to your manufacturer's website to download the latest. For ATI, its Catalyst. For nVidia it's Forceware. Just remember you need a 32 bit version of Windows XP or Vista or 2000 to operate these drivers properly. There are no real 64 Bit ones yet, and your drivers will fail to install on a 64 bit machine.

-Insufficient or Ineffective RAM
Get more RAM, make sure its of the right frequency so it doesnt lead to incompatibility. Eg. If you can support DDR 400, then get them both at DDR400 and have the same voltage. You will need to look at the sticker that comes on the RAM and break down the format to extract this information.

If you think it's a certian stick of RAM and you have more than 1, take out one, and run Warcraft III. Then repeat for your other RAM. If one stick is causing the crash, then replace it with one that works. If it's 1, then you will need to replace it. The best way to detect this problem is checking your crash logs and looking for the memory address that crashed. You can also install and run MemTest86 to find out which addresses aren't complying and which ones are.

-Motherboard Conflicts
This is one nasty mother ****er. You would need to either update your current drivers. Or even go as far as Flashing a new BIOS (requires reinstall and hopes that it doesnt crash in reinstallation). Or even to disect your computer and install a new motherboard (4-5 hrs. you dont want to do). This is a rare occurance, I have never seen a Motherboard conflict, unless you did something stupid like drop a magnet on it or broke a piece of it.

-PSU not strong enough (STRONG POSSIBILITY)
This is the most common problem that is often overlooked. It happened to me when I owned a JGE 300W PSU before I got it replaced. It wasn't passing enough volts through the 12V Line (15A). Open your case, and look at your PSU label for the 12V line(not colour, the AMPS). If the number is below 20-22A, then you need to get it replaced. Its not sending a powerful enough current through the motherboard to power everything! For watts, aim towards 450+ to your PSU. However, brand will determine how AWESOME it is. Get a well known name brand (Antec for example), otherwise the PSU could fry or explode if the parts are cheap or defective (we can't have that). Plus, some brands don't have good warranties, so you cannot get a proper replacement should anything happen to it.

-Your running 3D sound with a card that doesnt support it (makes a different error message)
This will make a different error message. Saying that the mp3 was failed to initialize. Users running a RealTek Audio chipset will have to turn off 3d sound to avoid this problem. If your sound card/chipset supports it, then you are safe and can turn it on. I recommend Sound Blaster Audigy or X-Fi to operate 3D Sound.

-You have anti-aliasing on (wc3 hates this feature, water.blp doesnt load right)
This was a bad issue back when ATI Catalyst was around 4.5-4.8. Anti-aliasing was always on and Warcraft III is a real prick when dealing with Anti-aliasing, mostly because the water models wouldnt be able to work properly. Find a way to turn it off, or install 4.10+ (anti-aliasing wasnt on default in those versions).

-You're running openGL (remove -opengl tag) from Properties
If you right click on your shortcut and select Properties, you'll find where your shortcut is running to. Look at the end of it, for the -openGL tag. This shouldn't be here. We live in a world of Direct3D now. The only purpose OpenGL servers is probably playing Unreal Tournament 1999 and Doom II, since these games actually looked better in OpenGL than Direct3D. Other games may not take OpenGL kindly.

-Virus (STRONG)
You could have a virus that is plaguing your system. You can run an anti-virus scan or reformat your hard disk. Reformating clears everything (requiring Windows reinstall) but you will have nuked the viruses. Use Norton (if you want a virus within itself) or AVG (it's free), Proxomitron or Spybot to keep these threats neutralized.

-Too Many programs running at once (STRONG)
Control Alt Delete > Close off any programs that you don't want running. To free up physical memory so your RAM doesn't overload and close Warcraft III. The only situation this is a problem is with programs that conflict with each other or if you blew your Virtual Memory cache (The portion of the Hard Drive that writes page files should you inflate your RAM).

-Models could be rendered incorrectly (updates and fixes, custom models)
Not really a common problem, was in DOTA!!! Some custom models may have not been done incorrectly and the game will crash. Not much you can do, update your game and use models that work properly for best effects.

-DRAM Voltage TOO LOW!!
Another problem, it requires you to tamper with your BIOS settings. Load up the BIOS the way would do it. Then find the option called DRAM Voltage (should be in Power Management). Set it to the maximum value. If your BIOS warns you about it being unsafe, just do it anyways. Be sure your PSU can take the heat.

-AGP Aperture Size
The value of this must be half of what your video card is (Eg. if its 256MB, then set Aperture to 128MB, and so on). If you use the full value, your card will stop working properly! By default, the Aperture of the card is usually set to Auto, which adjusts based on the card installed.

-Fast Writes and XAGP
My old Windows XP machine usually had this at 4x and Fast Writes on. If your computer can support it, go 8x and Fast Writes. However, your motherboard needs to have the feature. BIOS has an option called AGP Fast Writes within it, it must be enabled to work properly. Check your motherboard specs to make sure you know what the limits are.

If parts get too hot, they will stop functioning properly. Use better fans or cooling systems to operate these parts and keep them cooled. It can also help to open your case to regulate hot air. Just make sure you keep the open side away from your feet, your dog or whatever. I recommend you only open the case when you want to install new parts.

-Internal Engine issues:
This happens to me in The last Sylvannas mission and the older versions of DOTA. It could preform an operation that the system really hates. Wait until future versions of the map come, it could solve the problem about whats happening. For me, this also happens sometimes when I cast Storm, Earth and Fire in Melee or when I transition a hero unit to something like a bear or a storm crow (hero > unit or unit > hero by skill, not trigger). As patches go on, some of these bugs are corrected.

-CD Cracks (for you warez boys out there :))
You most likely have a CD key or an illegal burned copy that needs libraries or certain files that would appreciate it if you had the real version. Do us all a favor and buy the REAL expansion, reinstall Wc3, and that should fix your problem.

If you decide to reinstall Wc3, keep your maps you want to keep in a seperate folder so you can copy them to the map folder later. The only reason you may want to reinstall is if you reformat your Hard Drive.

If you need any further questions, PM me or contact me on MSN. If you do so in a inpolite way, have had the problem only occur once or rarely; I will NOT! answer you back, I may even block you. I want to help, but I am a busy person sometimes and I don't appreciate getting **** yous or assholes when I want to explain how to fix your motherboard problems.
Not open for further replies.